ColdFusion 11 Update 7 and ColdFusion 10 Update 18 are now available

This post is to announce the release of new updates for ColdFusion 11 and ColdFusion 10.

ColdFusion 11 Update 7

ColdFusion 11 Update 7 includes support for Windows 10 and OS X 10.11. Tomcat has been upgraded to version 7.0.64. This update addresses a vulnerability mentioned in the security bulletin APSB15-29 and also includes bug fixes related to connector, database, language, caching and certain other areas.

For more details, refer to this article.

ColdFusion 10 Update 18

ColdFusion 10 Update 18 includes support for Windows 10 and OS X 10.11. Tomcat has been upgraded to version 7.0.64. This update addresses a vulnerability mentioned in the security bulletin APSB15-29 and also includes bug fixes related to connector, language, caching and certain other areas.

For more details, refer to this article.

For those who have applied the early access release (pre-release) build of Update 7 or Update 18, follow the steps below to reinstall Update 7 or Update 18, as applicable.

1.     Uninstall Update 7 (PreRelease) or Update 18(PreRelease). 

2.     Reinstate the update URL by clicking on the “Restore Default URL” button in the “Server Updates” section in the ColdFusion administrator.

3.     Switch to the “Available Updates” tab and click on the “Check for Updates” button.

4.     Download and install Update 7 or Update 18.

 

54 thoughts on “ColdFusion 11 Update 7 and ColdFusion 10 Update 18 are now available

  1. Oooh, the changelog lists this as fixed:
    > 3822982 “Report Execution Times” is prohibitively slow on large apps

    Hooray! If we can actually get accurate values without killing the application that’ll be handy when doing performance tuning.

    Just need to wait for the fix to bug 3956389 to be released to make updating a possibility. :/

  2. Tried to update ColdFusion 10 Developer Edition from Update 17 to 18 and now ColdFusion’s primary service won’t start. It’s stuck in the ‘starting’ stage. Had to reboot in safe mode and restore from the backup files in hf-updates.

    Attempted the update again with same result. Update log shows no errors:

    318 Successes
    0 Warnings
    0 NonFatalErrors
    0 FatalErrors

    Restoring from backup again.

    System specs: Windows 7 X64, IIS 7, ColdFusion 10 Developer.

  3. Using Windows CF10 Developer Update 17 (Windows Server 2008 R2), I attempted to “download” the updates prior to installing and am now stuck with “503 Service Unavailable”. I can’t even access static, non-CFM files. I’m glad I tested it internally prior to blindly trusting that it would work the first time. Any official recommendations from Adobe?

  4. I did. That’s the first thing I always try. I’m sorry that I didn’t include that in my initial response. That didn’t work, but ColdFusion did respond after rebooting the server. I’m going to create a restore point before I continue.

  5. Are any instructions for manual installation going to be provided? I’m not sure why it didn’t work, but would like to know if there are any alternatives since I don’t trust the built-in updater that much.

  6. @Nimit, yes I rebooted and the service was still stuck in the “starting” status. The only way I could uninstall the update was to reboot in safe mode and manually roll back the update.

  7. David,
    What is the update level of your CF 10 server prior to the update? Do you have single CF server instance or multiple CF server instances in a cluster?
    Can you pls. try starting the CF server manually from the windows command processor console post-update, and share the console output.

  8. Hi,
    and once again I don’t see the Version-No mentioned in the article.
    My Version after Update 18/7: 10,0,18,282462 and 11,0,07,289974
    Version expected: 10,0,18,296330 and 11,0,07,296330

    I’m running CF10 Standard on Ubuntu 12.04 64bit
    and CF11 Standard on Ubuntu 14.04 64bit
    Jörg

  9. Hi Jörg,
    You reported this during the last update release as well. The last time the update level was updated but the build no. was not. You send me the logs files but there were no failures or warnings in there.
    The cfinfo output you shared indicated an old build no. with a newer update level, even prior to applying update 17/6.
    Now, can you confirm if the build no. was invalid prior to applying yesterday’s update.
    Is this issue limited to a single instance of CF10 and CF11, or observed with more than one instances.
    Can you also check the new update install logs for any reported issues.
    We can try replicating the issue in an OS similar to yours. I don’t remember if we did that the last time you reported this.

  10. Hi Piyush,
    yes I can cnfirm that the build no. was invalid/wrong prior to the update since we came to no conclusion the last time 🙂
    This is not limited to a single / the both instances.
    I have a Windows 10 64bit machine with CF11 dev that now mentions 11,0,07,292866.

    But: Our dev/staging machine running Ubuntu 12.04 32bit! with a recently installed CF11 dev now shows 11,0,07,296330

  11. Thanks for the confirmation, Jörg.
    We did not observe this on Windows 10 at our end. I’ll check the internals to see how the build no. is picked to be displayed in the CF admin.

    James,
    We did not observe any issues when updating from a 2-instance CF10 cluster on update 17 to update 18.

    Can you share the update install log from the defunct update installation.
    Why don’t you drop a note to our support folks at cfsup@aodbe.com. They can coordinate with you to monitor the
    update process, if you are willing to try that again. Nothing like observing it first hand.

  12. @Piyush, my version prior to update was: 10,0,17,295085.

    Just to be totally safe I rolled back my installation to Update 15. I then stopped all coldFusion services and set the primary service to “Manual” to prevent it from starting automatically.

    I then re-installed update 17 manually by executing the hotfix_17.jar file. The install wizard completed successfully. I restared coldfusion services and confirmed everything is working properly.

    I then shut down coldFusion services again and manually installed hotfix_18.jar. The wizard reported a successful update. I then attempted to restart coldFusion services and again it was stuck in the “starting…” status. I rebooted and attempted to start the service and it remained stuck in the “starting…” status.

    I believe something may be wrong with hotfix 18 on Windows7 X64.

  13. Hi David,

    Could you please show the context.xml here. Location C:ColdFusion10cfusionruntimeconf.

    In case Manager pathname entry is commented, just uncomment it and it will work.

  14. I tried to apply CF11 Hotfix 7 on the first of several development systems where I am running CF11 w/HF6 deployed on Java 1.8.0_66 and stock Tomcat 7.0.65. Downloaded HF7 jar via the Updates page in the CF admin, stopped CF11, then installed HF7 via command-line (java -jar ./hotfix-007.jar -i GUI). It reports the following in the hotfix log:

    Installation: Unsuccessful.

    776 Successes
    0 Warnings
    1 NonFatalErrors
    1 FatalErrors

    Action Notes:

    Failed to copy hotfix files:/tmp/925428.tmp/dist/cfusion: Failed to copy the hotfix files to the target location. Retry installation after ensuring that the server is not running or files are not locked by the server.

    Rebooted system to ensure files weren’t somehow locked, and attempted again to apply hotfix. Identical errors in the log file.

    I can provide the full log by email if that will help figure out what’s amiss.

  15. We had a similar issue with CF11 hotfix 7. I checked the logs and found it that it could not move one file to backup or delete it. The file is ColdFusion11cfusionruntimelibecj-P20140317-1600.jar. We made sure CF was stopped and also made sure there was no AV or anything else interfering.

    Keeping an eye on this thread to see if there is a solution posted.

  16. Just to see what would happen I manually stopped CF, renamed the offending file, restarted CF, then ran the update. The hotfix installed fine with no errors.

  17. Hi Jörg and Piyush,

    I can confirm the problem with the reporting version number.

    On Windows Server 2008 R2 the Coldfusion 10 Version number after Update 18 is now: 10,0,18,283922 and NOT 10,0,18,296330.

    Kind regards,

    Patrick Schütz

  18. Jörg and Patrick,

    Can you confirm if what you are sharing is the information displayed in the CF admin. Is the info output by the cfinfo tool the same? I think these two things use different mechanism to pull the info.
    Can you also check and confirm the contents of the /cfusion/lib/updates directory.

  19. Hi Piyush,

    I can confirm that the version is displayed in the CF admin.
    The same version “ColdFusion Server 10,0,18,283922” is displayed by the cfinfo tool.

    In /cfusion/lib/updates is only one file: “chf10000018.jar”.

    Kind regards from Germany,

    Patrick Schütz

  20. Hi Piyush,
    same on my side… just tested our CF11 server with cf-info.sh:
    11,0,07,289974
    Base Version:
    11,0,0,289974

    Even more regards from Germany 😉
    Jörg

  21. Are there updated installers?

    It’s kind of a huge pain to install this on Windows 10 using the series of workarounds we have to work through. Is there even a release note that mentions the downloadable wsconfig.jar that you are only hosting on this blog?

    How about at least updating the release notes with the actual step-by-step process required to install CF11 on Windows 10?

    As it stands, your release notes make it seem like you can use the installer, but this is not true. You have to:

    1. Run the installer
    2. Download wsconfig.jar from a random blog post here.
    3. Figure out where to put wsconfig.jar
    4. Run the Web Server Config Tool.
    5. Add the connectors.
    6. Complete the install process by visiting the CF admin.
    7. Run the update to bring it up to 7.
    8. Rerun the web server config tool to remove bindings.
    9. Rerun the web server config tool to re-add bindings.

    I don’t know about you, but this isn’t an install experience I would want for my software. It actively discourages users.

  22. I want to apply Update 7 to a clean install of downloaded CF 11 (Developer eDITION) applied to Windows 10 but, as before Update 7 was available, I cannot Add an IIS Webserver because IIS 10.0 is not supported.
    All ColdFusion Services run but I cannot run Administrator because in my inetpubwwwroot the CFIDEadministratorindex.cfm structure was not installed.
    It only exists in cfusionwwwroot and run from there it reports HTTP Error 404.0-Not Found because the expected physical path does not exist.
    I assume that I will have to apply Update 7 before I can select IIS 10.0 as Webserver. However, without a way to run the Administrator, please provide the command line steps to accomplish this, AND a URL where I can download update 7 from without having the Administrator to do this for me.

  23. @Roland, I agree that Adobe should roll out fresh installers with Windows 10 support for ColdFusion 10 and 11. I’ve been told that it’s a hassle for them to get all their ducks in a row for a full-fledged installer (something to do with Adobe’s legal department) but I think it would be worth it in the long run and it definitely make Adobe’s customers happier.

  24. @Charlie: many thanks. With your help there now is a full process for a clean Coldfusion 11 install in Windows 10 (64bit).
    1. Install IIS (10.0) by activating this as one of your Windows Features.
    2. Download the Akamai Netsession ‘Download Manager Installer’
    3. Download Coldfusion_11_WWEJ.win64.exe
    4. Run Coldfusion11 in C:Coldfusion11 default folder (and MS Visual C++ 2012 package; likely necessary). I installed my ‘Developer’ Edition for use in localhost (127.0.0.1) selecting “All IIS websites” an setting my administrator password.
    5. Component Services show that “IIS Admin Service”, the “Coldfusion11 Application Server” and other Coldfusion11 services selected are running.
    6. The Administrator fails to run from the Windows10 link created because the URL target does not exist: http//127.0.0.1:80/CFIDE/administrator/index.cfm
    7. This prevents the prescribed install of the hotfix_007.jar “Update 7” (downloaded from https://helpx.adobe.com/coldfusion/kb/coldfusion-11-update7.html) that is required for Windows10.
    8. The incompatibility with the IIS10.0 is demonstrated if you try to install a Webserver using the Windows10 “Coldfusion Webserver Configuration Tool”.
    9. Charlie’s install of a hotfix from the command line noted above worked like a charm after I copied the hotfix_007.jar file copied into the Windows/System32 folder.
    10. At the Elevated Command Line prompt (Run as Administrator) C:WindowsSystem32> was then typed:
    C:Coldfusion11jrebinjava -jar hotfix_007.jar
    11. Hitting Enter starts the CF update process: follow instructions. The hotfix is installed in Coldfusion11cfusionhf-updateshf-11-00007
    12. The webserver automatically restarted (verify as suggested).
    13. The Webserver Configuration Tool now allows you to select for localhost “All IIS” website and complete the process that prior to the hotfix would report that IIS 10.0 was not supported.
    14. This process reports the addition of VDIR objects “Default Web Site/jakarta” and “Default Web Site/CFIDE”.
    15. The CF Administrator link created is now functional so that you can configure your CF webserver after entering your admin password.

  25. Guys, all due respect, but this is a preposterous situation.

    Tell me this: how would a new programmer, who enthusiastically keeps up to date with their tools and operating systems, who still hasn’t been jaded by the industry, who may become a lifelong ally of your ecosystem, perceive the state of this product if they can’t easily install it?

    You’re doing a massive disservice to adoption. There’s a reason I have to apologize for ColdFusion to my customers, and this exemplifies it.

    I wasn’t being constructive. I was bitching. I’ve stood up for this platform for almost 20 years now, yet I still have to defend my choice. You don’t make my job easy.

    Sigh.

  26. I have used the “unsubscribe” link to unsubscribe from this thread about five times now. but still I get email for every bloody comment. Can you please stop f***ing spamming me?

    Thanks

  27. Feedback on Charlie’s questions:
    1. At step 4 in my process, I could NOT select the “Built-In web server” because it did not allow me to define it and get access to the Administrator: before hotfix_007.jar is applied, I could not access it (unless I would have Appache available, which I did not).
    2. The location of the hotfix_007.jar file in step 9 assured that it was found from the elevated command prompt as this location would be independent of any PATH-variable dependent access.
    While my ’15-step’ process will work, I agree with everyone that the downloadable CF11 file should be upgraded by Adobe through hotfix-7 as the simple way to assure broad and simple support for Windows 10 etc.

  28. Adobe really should update the installers by now. I know it’s a hassle for them but seriously, you should be able to get up and running with ColdFusion on Windows 10 without having to hack your way through the install.

  29. Thanks David (#57) and Charlie (#58) for your input.

    I spoke with ViKram ( CF installation expert @ Adobe) and we were not able to get CF running on my Windows 10 system. We then download another version of the setup file via FTP site provided by Vikram co-worker. With this setup file, no problem with the installation and CF work just fine.

    Vikram thought that it was a bad download. So, I perform a little test. I re-download the file and re-run the installation using the new download setup file. Same problem, CF 2016 service was not created and start CF manually ( CFstart) did not resolved the problem. Uninstall CF, reinstall CF using the FTP setup file. Again no problem! We do not know the exact nature of the problem but using the setup via FTP just work.

    Problem solved using the setup file provided by Adobe tech support (Vikram) via FTP.

    I hope this help other CF’er facing this abnormal issue.

  30. is it possible to update the Tomcat version that ColdFusion is built upon? our Nessus security scans are complaining that TomCat is not uptodate (older than 7.0.68). is there a CF11 update on the horizon that will address this ? we do have update 7 installed for CF11 .. and that only supports TomCat version 7.0.64

Leave a Reply

Your email address will not be published. Required fields are marked *