Recently ColdFusion 11 update 1 was out and blogged here. The technote lists the bug fixes included in this specific update.

In case you are unable to apply the update directly from the ColdFusion Admin, here are some tweaks you can try:-

Start ColdFusion from command line and apply the update

  1. Stop ColdFusion service or ‘ColdFusion 11 Application Server’ service.
  2. Launch command prompt with “Run as Administrator” feature.
  3. Navigate to \ColdFusion11\cfusion\bin\
  4. Type cfstart.bat and hit enter.

Once the server startup message appears on the prompt, navigate to ColdFusion Admin and apply the update.

Apply the update manually

Download the hotfix from here and then you can follow the instructions to apply the update.

Apply the “Service startup fix” first and then update 1

  1. In case the above two suggestions doesn’t work, then first apply the service startup hotfix hf1100-3776060 and then Update 1.
  2. Download the hotfix from hf1100-3776060.jar
  3. Place this hotfix at \ColdFusion11\cfusion\lib\updates\
  4. Restart the ‘ColdFusion 11 Application Service’.
  5. Navigate to ColdFusion Admin and apply the update.

Note: The above cases are based upon user scenarios/environments. All the other updates should be applied via the ColdFusion Administrator directly.

20 Comments to “Unable to apply ColdFusion 11 Update 1”

  1. Shawn
    where do CF systems stand with this new vulnerability? CF software use Bash shell?

    http://www.cnet.com/news/bigger-than-heartbleed-bash-bug-could-leave-it-systems-shellshocked/
  2. Louis
    I just applied the update on a windows 2003/IIS6 box. All seemed to go well until the end when it tried to restart the cf server. I rebooted, tried restarting IIS, CF App server and nothing helped. The Default Application Pool would not start and all websites stopped working. I tried re-connecting an individual site instead of All and that didn't work. I manually uninstalled the update and all is OK. Why did this happen? Anyone else have this issue? This was a devlopement server and I'm glad I didn't try it on our production server. The only unusual thing about the setup is CF 11 is located on a D drive. I'm just guessing. Please help
  3. Miguel-F
    [subscribe]
  4. Anit Kumar Panda
    @Shawn, Adobe is working on it, including the CF team.

    @Louis, You may like to check the updater log within the ColdFusion directory for more info. Please let us know, if you face any challenge further.
  5. Louis
    The update log only shows success for each item so CF updated itself without error. What I can't seem to find is a specific reason why the Default Application pool had an unspecified error and would not start. Event log showed this file not being found: isapi_redirect.dll. Logs shows the error below. Something about this update is not compatible since reverting back and all is good.

    SEVERE: The web application [/] created a ThreadLocal with key of type [coldfusion.util.DateUtils$1] (value [coldfusion.util.DateUtils$1@63658a]) and a value of type [java.util.GregorianCalendar] (value [java.util.GregorianCalendar[time=1411960003375,areFieldsSet=true,areAllFieldsSet=true,lenient=false,zone=sun.util.calendar.ZoneInfo[id="America/New_York",offset=-18000000,dstSavings=3600000,useDaylight=true,transitions=235,lastRule=java.util.SimpleTimeZone[id=America/New_York,offset=-18000000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=3,startMonth=2,startDay=8,startDayOfWeek=1,startTime=7200000,startTimeMode=0,endMode=3,endMonth=10,endDay=1,endDayOfWeek=1,endTime=7200000,endTimeMode=0]],firstDayOfWeek=1,minimalDaysInFirstWeek=1,ERA=1,YEAR=2014,MONTH=8,WEEK_OF_YEAR=40,WEEK_OF_MONTH=5,DAY_OF_MONTH=28,DAY_OF_YEAR=271,DAY_OF_WEEK=1,DAY_OF_WEEK_IN_MONTH=4,AM_PM=1,HOUR=11,HOUR_OF_DAY=23,MINUTE=6,SECOND=43,MILLISECOND=375,ZONE_OFFSET=-18000000,DST_OFFSET=3600000]]) but failed to remove it when the web application was stopped. Threads are going to be renewed over time to try and avoid a probable memory leak.
  6. Anit Kumar Panda
    If the update log was clean and the "Default App pool" didn't start, then you need to check for the Windows Event Viewer logs. Check the "Application" logs under "Windows Logs". With the description of the "App pool" error, you will be able to identify the cause.

    On the other hand, the stack you shared is a warning from Tomcat and has nothing to do with the update process.
  7. Louis
    Unfortunately the only thing the windows logs showed was that IIS couldn't find isapi_redirect.dll. I just can't figure out why the update was changing something in IIS. I can do it once again to see but reverting back works and no more errors. Is there anything in this update that can change the way the App Pool finds isapi_redirect.dll ?
  8. Anit Kumar Panda
    Can you try once again applying the hotfix. If still you face any challenge, then please contact us at cfinstal<AT>adobe<DOT>com OR cf<DOT>install<AT>adobe<DOT>com
  9. charlie arehart
    @Louis, just a point of clarification for you (and readers of your notes). You wonder "why the update was changing something in IIS", because the Windows event log showed IIS not able to find the isapi_redirect.dll.

    To be clear, that file is an Adobe-provided file, and is THE connector that connects IIS to CF. There's nothing new about it in this updater, or in CF11.

    When you connect CF to IIS (whether using the original CF 10/11 installer or the CF web server connector tool), that file would be placed in a CF directory ([cf]\config\wsconfig\[n]), and then the installer or tool would configure IIS to point to it (in handler mappings, isapi filters, and the jakarta virtual directory for any sites connected to CF).

    So when you say it could not be found, there's really two questions: was it where it should have been put? and was IIS configured properly to point to that.

    And actually, I don't think the update itself manipulates either the file or IIS. Do you mean perhaps that after doing the update, you ran the web server configuration (wsconfig) tool, as indicated in the update?

    If so, did you use "run as administrator" to do it, as indicated in the technote? It's a rather subtle point there that's easy to miss. But it's very important to do, to get the tool to properly configure both CF and IIS (yes, even if you "are" an administrator on your server).

    Hopefully you will take up Anit's offer to reach out to them directly for help. I could see this being some form of a permissions issue, but let's hear once you guys resolve things.

    Hope that's helpful.
  10. Shawn
    So I'm getting pretty deep into the new charts version for the first time, and they GREATLY need improvements, hopefully via an update. I'm spending more time trying to UNDO all coldfusion's non professional default styling than I am actually working with the charts. The complaint list is mounting by the hour.

    - "plain" is the default and only paintStyle in CF11? The package itself defaults to "gradient" and you go out of your way to make the charts look uglier by forcing me to use plain if I don't want to use your default colors

    -the colors you guys chose for the data sets are so bland and boring. Please when your working on visualization get someone on it with a design eye. Dry blue to light dry blue are terrible chart colors. They may match your product colors, but to actually pick them based on that just shows the frame of mind was in the wrong place. The labels aren't even readable on a white background.

    -matching the ugly color scheme the background is also using an ugly blue/green grey. I really don't know how you can pick anything but white or transparent as a default and let the divs handle it. Default should be clean and professional, not ugly.

    -title doesn't hide when not supplied. It puts a random empty box on the screen.

    -cfchart style as a file name is the most nonfunctional path parameter I've ever seen. It can't handle folder structures or query strings on the url. Anything but in the current folder fails. Which creates issues creating fully dynamic json styling with no query string

    -So I'm trying to use style as a file to override all these bad decision defaults and I have the chart where I want it in json, but I need dynamic data. So I try to remove the values from the json file and include them as cfchartdata and when I do this CF blows away all my styles and goes with its own again.

    -so as a last ditch effort I'm trying to track down the CF config file for charting styles and the documentation is terrible and out of date and the folders are so messy. There are 6 or so different pie chart files. None of them seem to have any effect.

    -The formatting of data isn't working. labelFormat="currency" has no effect.

    -Scaling issues. I set a 350x350 pie chart and the pie chart itself was like 70x70 in size with HUGE margins. Another misguided default.

    After fiddling with ZingChart's builder I can see they are not the problem. Its default styles look fine, its ColdFusion that went in an overrode it all to a level its unusable.

    The hope was that CF would make this quick and painless and I'm finding out CF is just getting in the way. That isn't a CF "doing it" problem its a CF "doing it right" problem. I think it should include charting, but not like this. It needs to be polished.
  11. Anit Kumar Panda
    Thank you for such a detailed analysis. We are working on the issues reported.
  12. Louis
    Thank you Charlie. All steps were taken and twice I had to revert back. You should not have to be a computer wiz to install an update. I'm contacting the install folks for assistance.
  13. Mark
    I am unable to click the link in order to update, even trying the work around. I'd prefer not to update manually. In IE 11.0.12
  14. Anit Kumar Panda
    Can you press Ctrl + F5 from your keyboard to refresh and then try to click on the notification for updates, within CF Admin. Alternatively, you can try from a different browser.
  15. Mark
    Installed FF and still have the same issue. can you provide the URLs this update connects to so I can test getting there directly?

    I know about this one... http://www.adobe.com/go/coldfusion-updates
  16. Anit Kumar Panda
    That is the correct url. Can you ensure that you are not behind any firewall/proxy as well. This could be another reason.
  17. Mark
    It took me a bit, but I figured it out. We have moved the scripts and I needed the virtual dir within the cfadmin site. Thanks for your help and my apologies for the bother.
  18. Anit Kumar Panda
    Glad that, you are able to resolve this.
  19. Shawn
    Anyone have any luck with using custom fonts with cfhtmltopdf? While the screen render is near pixel perfect, its 1 imperfection I see is it didn't pick up the custom fonts being used. Were custom fonts overlooked? I can't seem to find any documentation online addressing it.

    Kind of a big deal, really keeps the tag from producing brochure quality PDFs without the same tools the designers have.
  20. Anit Kumar Panda
    Can you check the Adobe bugbase (https://bugbase.adobe.com/) for existing bug, if any. Please log a new bug, if there isn't an older one.

Leave a Comment

Leave this field empty: